Descripción

El propósito de una VRRP es comunicar a todos los VRRP's asociados con el ID de router virtual y el soporte de redundancia de routers a través del proceso de elección de prioridades entre ellos.

Diagrama de red

Objetivo

Realizar una conexión con salida a internet y una configuración básica de VRRP para lograr redundancia en nuestra red usando como apoyo otra VRRP.

Desarrollo

Creamos un bridge en modo stp entre los puertos ether2 y ether3 y le asignamos al bridge la ip: 172.19.1.253

[R1] /interface bridge> add name=bridge1 protocol-mode=stp 
[R1] /interface bridge port> add interface=ether2 bridge=bridge1 
[R1] /interface bridge port> add interface=ether3 bridge=bridge1 
[R1] /ip address> add address=172.19.1.253/24 interface=bridge1 
[R1] /ip route> add dst-address=192.168.1.0/24 gateway=172.19.1.254

Agregamos la VRRP para la red 172.19.1.0

[R2] /ip address> add address=192.168.1.1/24 interface=ether1
[R2] /interface vrrp> add name=vrrp1 interface=ether1 vrid=49 priority=254
[R2] /ip address> add address=192.168.1.254/24 interface=vrrp1
[R2] /ip address> add address=172.19.1.1/24 interface=ether2
[R2] /interface vrrp> add name-vrrp interface=ether2 vrid=2 priority=100
[R2] /ip address> add address=172.19.1.254/24 interface=vrrp

[R3] /ip address> add address=192.168.1.2/24 interface=ether1
[R3] /interface vrrp> add name=vrrp1 interface=ether1 vrid=49
[R3] /ip address> add address=192.168.1.254/24 interface=vrrp1
[R3] /ip address> add address=172.19.1.2/24 interface=ether2
[R3] /interface vrrp> add name=vrrp interface=ether2 vrid=2 priority=200
[R3] /ip address> add address=172.19.1.254/24 interface=vrrp2