Descripción

DHCP Relay es un proxy que es capaz de recibir una solicitud de DHCP y reenviarlo al verdadero servidor DHCP.

Sub-menú: /ip dhcp-relay

Diagrama de Red 

Objetivo:

Demostrar como configurar un DHCP-Server y un DHCP-Relay que sirve para dos redes que están en el  Router R2.

Configuración Router1 (R1)

En este equipo denominado "R1" vamos a realizar la configuración de dos servidores  DHCP que necesitamos para nuestras LANs.

Agregamos las direcciones ip respectivas para la salida a internet y la conexión al dispositivo R2:

[R1] /ip address> add address=74.125.229.230/29 interface=wlan1
[R1] /ip address> add address=10.10.1.1/30 interface=ether2

Creamos los pools de direcciones para los dhcp-server que vamos a crear:

[R1] /ip pool> add name=pool1 ranges=192.168.1.2-192.168.1.254
[R1] /ip pool> add name=pool2 ranges=192.168.2.2-192.168.2.254

Configuramos los dos dhcp-server en la interface ether2 , asignamos el pool de direcciones y dhcp-relay respectivo para cada uno de los servidores:

[R1] /ip dhcp-server> add name=Server1 interface=ether2 relay=192.168.1.1 address-pool=pool1 disabled=no
[R1] /ip dhcp-server> add name=Server2 interface=ether2 relay=192.168.2.1 address-pool=pool2 disabled=no

Configuramos las respectivas redes:

[R1]/ip dhcp-server network> add address=192.168.1.0/24 gateway=192.168.1.1 dns-server=209.85.253.116
[R1]/ip dhcp-server network> add address=192.168.2.0/24 gateway=192.168.2.1 dns-server=209.85.253.116

Agregamos la ruta por default y las rutas hacia las redes del dispositivo R2:

[R1] /ip route> add dst-address=0.0.0.0/0 gateway=74.125.229.230
[R1] /ip route> add dst-address=192.168.1.0/24 gateway=10.10.1.2
[R1] /ip route> add dst-address=192.168.2.0/24 gateway=10.10.1.2

Configuramos las reglas de nat para la salida a internet desde las PC conectadas en las LANs:

[R1] /ip firewall nat> add action=masquerade chain=srcnat src-address=192.168.1.0/24 out-interface=wlan1
[R1] /ip firewall nat> add action=masquerade chain=srcnat src-address=192.168.2.0/24 out-interface=wlan1

 

Configuración Router2 (R2)

En este equipo denominado "R2" solo configuramos las direcciones ip en las interfaces respectivas y la creación de los dhcp-relay para cada LAN.

[R2] /ip address> add address=10.10.1.2/30 interface=ether1
[R2] /ip address> add address=192.168.1.1/24 interface=ether2
[R2] /ip address> add address=192.168.2.1/24 interface=ether3

Al configurar un dhcp-relay, lo vamos a asignar a la interface donde se encuentra nuestra conexión LAN, la dirección local de nuetra red LAN1 o LAN2 y la dirección de interface donde se encuntra configurado los dhcp-server:

[R2] /ip dhcp-relay> add name=Relay1 interface=ether2 dhcp-server=10.10.1.1 local-address=192.168.1.1 disabled=no
[R2] /ip dhcp-relay> add name=Relay2 interface=ether3 dhcp-server=10.10.1.1 local-address=192.168.2.1 disabled=no