Descripción

DHCP Relay es un proxy que es capaz de recibir una solicitud de DHCP y reenviarlo al verdadero servidor DHCP.

Sub-menú: /ip dhcp-relay

Diagrama de Red

Objetivo

Configurar un HotSpot para cada una de las LANs que tenemos en el dispositivo R3, donde se encuentra configurado muestro DHCP-Relay.

Configuraciión Router1 (R1)

Configuramos las direcciones Ip:

[R1] /ip address> add address=74.125.229.230/29 interface=wlan1
[R1] /ip address> add address=10.10.1.1/30 interface=ether2

Creamos los pools de direcciones para los dhcp-server que vamos a crear:

[R1] /ip pool> add name=pool1 ranges=192.168.1.2-192.168.1.254
[R1] /ip pool> add name=pool2 ranges=192.168.2.2-192.168.2.254

Creamos los DHCP-Server:

[R1] /ip dhcp-server> add name=Server1 interface=ether2 relay=192.168.1.1 address-pool=pool1 disabled=no
[R1] /ip dhcp-server> add name=Server2 interface=ether2 relay=192.168.2.1 address-pool=pool2 disabled=no

Configuramos las respectivas redes:

[R1] /ip dhcp-server network> add address=192.168.1.0/24 gateway=192.168.1.1 dns-server=209.85.253.116
[R1] /ip dhcp-server network> add address=192.168.2.0/24 gateway=192.168.2.1 dns-server=209.85.253.116

Agregamos la ruta por default y las rutas hacia las redes del dispositivo R3:

[R1] /ip route> add dst-address=0.0.0.0/0 gateway=74.125.229.230
[R1] /ip route> add dst-address=192.168.1.0/24 gateway=10.10.1.2
[R1] /ip route> add dst-address=192.168.2.0/24 gateway=10.10.1.2

Configuramos las reglas de nat para la salida a internet desde las PC conectadas en las LANs:

[R1] /ip firewall nat> add action=masquerade chain=srcnat src-address=192.168.1.0/24 out-interface=wlan1
[R1] /ip firewall nat> add action=masquerade chain=srcnat src-address=192.168.2.0/24 out-interface=wlan1

Configuración Router2 (R2)

Configuramos las direcciones Ip:

[R2] /ip address> add address=10.10.1.2/30 interface=ether1
[R2] /ip address> add address=20.10.1.1/30 interface=ether2

Agregamos la ruta por default y las rutas hacia las redes del dispositivo R3:

[R2] /ip route> add dst-address=0.0.0.0/0 gateway=10.10.1.1
[R2] /ip route> add dst-address=192.168.1.0/24 gateway=20.10.1.2
[R2] /ip route> add dst-address=192.168.2.0/24 gateway=20.10.1.2

Configuración Router3 (R3)

Configuramos las direcciones Ip:

[R3] /ip address> add address=20.10.1.2/30 interface=ether1
[R3] /ip address> add address=192.168.2.1/24 interface=ether2
[R3] /ip address> add address=192.168.2.1/24 interface=ether3

Agregamos la ruta por default y la ruta hacia la red del dispositivo R1

[R3] /ip route> add dst-address=0.0.0.0/0 gateway=20.10.1.1
[R3] /ip route> add dst-address=10.10.1.0/30 gateway=20.10.1.1

Configuramos DHCP-Relay

[R3] /ip dhcp-relay> add name=Relay1 interface=ether2 dhcp-server=10.10.1.1 local-address=102.168.1.1 disabled=no
[R3] /ip dhcp-relay> add name=Relay2 interface=ether3 dhcp-server=10.10.1.1 local-address=192.168.2.1 disabled=no

Configuración HotSpot en Router3 (R3)

HotSpot en interface ether2

[R3] /ip hotspot> setup

Select interface to run HotSpot on
hotspot interface: ether2

Set HotSpot address for interface
local address of network: 192.168.1.1/24

masquerade network: no

Set pool for HotSpot addresses
address pool of network: 192.168.1.2-192.168.1.254

Select hotspot SSL certificate
select certificate: none                   

Select SMTP server
ip address of smtp server: 0.0.0.0

Setup DNS configuration
dns servers: 10.10.1.1

DNS name of local hotspot server
dns name:

HotSpot en interface ether3

[R3] /ip hotspot> setup

Select interface to run HotSpot on
hotspot interface: ether3

Set HotSpot address for interface
local address of network: 192.168.2.1/24

masquerade network: no

Set pool for HotSpot addresses
address pool of network: 192.168.2.2-192.168.2.254

Select hotspot SSL certificate
select certificate: none                   

Select SMTP server
ip address of smtp server: 0.0.0.0

Setup DNS configuration
dns servers: 10.10.1.1

DNS name of local hotspot server
dns name: